Solved

Usage Interval not reaching 100% on the last day

  • 11 November 2023
  • 2 replies
  • 111 views

Badge

Hi team, I just posted this question under the FAQ article, but I’m raising it here as well for the visibility’s sake with hopes to receive the answer faster. I don’t see this question being asked anywhere in this forum or under the FAQ.

 

One thing that I keep running in to with most of my Usage Interval charts is the fact that they never reach a 100% on the last day of the chosen interval (usually 60 days), even though I clearly state in the segmentation part that only users who performed that returning action 2 or more times in the same time period should be taken into consideration.

I was expecting to see a 100% by the last day but it’s never the case.

 

Do you have any idea why this is the case?

What am I missing?

 

icon

Best answer by paladin8 21 November 2023, 09:35

View original

2 replies

Badge

Bump :)

Userlevel 4
Badge +2

I’m assuming by “I clearly state in the segmentation part that only users who performed that returning action 2 or more times in the same time period should be taken into consideration” you mean that you’ve specified a segment that includes only users that perform the event at least 2 times in the time window.

The explanation here is that if the user performs the event twice in the same day, they do not count toward any usage interval, so the “performed at least 2 times” condition is insufficient to guarantee convergence to100% in the usage interval chart.

If, instead, you create a cohort specifically of users who perform the event with “count in interval” of at least 2 distinct days, applying that to the usage interval chart will show the 100% (barring minor discrepancies from real-time data).

Hope this helps!

Reply