Question

Cohorts not filtering properly when added to chart

  • 21 November 2023
  • 2 replies
  • 65 views

Hello!

 

Problem

I am trying to create 2 cohorts based on the registration types we currently have out in different countries. So I’m trying to segment by country. I’ve tried 2 different ways:

  1. Using the User Property `Country`
  2. Using one of my own events with an event property called `country`

When I go to create a chart using a funnel and I Segment by the Cohort, it pulls in more countries than exist in the cohort I create.

 

Example with images:

This is the Cohort I created using an event property called Full Reg Users

This is the result when added to a chart

Here’s how I’m using the Cohort in the chart

 

Using the user property acts the exact same way. Why is it pulling more countries than I put in the cohort? Shouldn’t it be filtering them out?

 

Why am I doing this?

I want an easy way to segment these users and someone else at the company can use it without worrying about which country is what. They can just use `Full Reg Users` Cohort and see what’s going on with them.

 

Thanks!


2 replies

Userlevel 5
Badge +9

Hi @Robert Malmstein. The reason for what you see is that the cohort is an include condition at the user level…i.e., the query is saying “give me any users that in the last 90 days triggered the Registration Started event where the country event property has a value of UK, US, MY, AU, SG or CA”. There is no exclude condition, so those same users will have triggered another event where the country event property had the values you’re not expecting (DE, FR, etc). If you want the users that ONLY had the values you’re targeting, you’ll need to add an exclude clause for all other possible values of the country event property.

Oh, I thought the `=` would make it exclusive. Is there no `exclusive` option to use here?

 

Also, I went ahead and added the exclusion to my Cohort and it works now! It’s more tedious to maintain as we add more countries to the list, but at least it works! Thank you!

Reply