Solved

Using Group Identify with Ampli when web application is created but group properties changing in events with different data

  • 18 January 2024
  • 1 reply
  • 42 views

Hi. I’m having an issue with the amplitude events showing different group_properties than originally set using groupIdentify. groupIdentify gets called once in the app to set the group properties for the events which should set it for future events. I noticed in the User Look-Up page in Amplitude Analytics, some of my events show the group_properties incorrectly while in the same amplitude session. Generic examples are below:

for one user:

  ampli.groupIdentify("animalShelterName", "Operation Kindness", {
animal: "Dog",
id: 5,
breed: "Poodle",
animalShelterName: "Operation Kindness",
})

The group_properties that show up in events in User Look-Up page in Amplitude Analytics on the same session, same user:

  "group_properties": {
"animalShelterName": {
"Operation Kindness": {
"animal": "Dog",
"id": 5,
"breed": "Golden Retriever",
"animalShelterName": "Operation Kindness"
}
}
},
  "group_properties": {
"animalShelterName": {
"Operation Kindness": {
"animal": "Cat",
"id": 13,
"breed": 13,
"animalShelterName": "Operation Kindness"
}
}
},
  "group_properties": {
"animalShelterName": {
"Operation Kindness": {
"animal": "Dog",
"id": 5,
"breed": "Poodle",
"animalShelterName": "Operation Kindness"
}
}
},

 

icon

Best answer by adriz 2 February 2024, 17:56

View original

1 reply

Issue seems to have been fixed by calling groupIdentify before each event. 

Reply