Solved

TypeScript Ampli Wrapper not compiling

  • 21 March 2023
  • 2 replies
  • 141 views

Hi,

Using npm dependencies @amplitude/ampli v1.31.2 and @amplitude/analytics-browser v1.9.1, the generated wrapper does not compile with our current TypeScript version 4.8.4. Documentation mentions a version requirement > 2.1

 

 

Also, event names containing single quotes also generate non-compiling code (our event names are written in natural french language). Single quotes seem to be handled properly on property names though.

 

icon

Best answer by Hadish 23 March 2023, 00:38

View original

2 replies

Badge +1

Based on the context provided, it seems that the TypeScript Ampli Wrapper is not compiling with the current TypeScript version 4.8.4. The documentation mentions a version requirement of greater than 2.1. Additionally, event names containing single quotes are generating non-compiling code. However, single quotes seem to be handled properly on property names.

 

Some references:
 

  

Based on the context provided, it seems that the TypeScript Ampli Wrapper is not compiling with the current TypeScript version 4.8.4. The documentation mentions a version requirement of greater than 2.1. Additionally, event names containing single quotes are generating non-compiling code. However, single quotes seem to be handled properly on property names.

 

Some references:
 

I’m sorry but how does this answer solve the case?

Reply