Question

Data missing from api response (event list)

  • 17 April 2023
  • 6 replies
  • 108 views

Badge

I am encountering an issue with the Amplitude API where I have noticed that some events contain segmentation data that is not present in the event list. Specifically, when querying the event list with the following Axios query:

{ url: "events/list", }

the event with the ID '56773164' is not included in the result. However, when querying the segmentation data with the following Axios query:

{ url: "events/segmentation", params: { e: { event_type: "_all", group_by: [ { type: "user", value: "event_type", }, ], }, start: "20230320T00", end: "20230320T00", m: "uniques", limit: 1000, }, }

the ID of the event can be found under seriesLabels in the response. What could be the cause of this discrepancy?


6 replies

Userlevel 5
Badge +8

@DPA thanks for writing in! I’m going to share this with our technical support team to look into.

Userlevel 5
Badge +8

Hi @DPA hope you’re doing well! Just wanted to check in and see if you saw the message from our support team so they can help troubleshoot further.

Badge

Hi @DPA hope you’re doing well! Just wanted to check in and see if you saw the message from our support team so they can help troubleshoot further.

Hello, hope you are doing well too.

Where can I see the message from the support team? 
Thank you

Userlevel 5
Badge +8

@DPA is looks like the support team sent you an email on May 6th. Do you mind checking your spam folder as well?

Badge

@DPA is looks like the support team sent you an email on May 6th. Do you mind checking your spam folder as well?

Hello Ester, 

Thanks for the confirmation. 
I checked the mailbox and also the spam folder.
However, I cannot find any received email on that day.  
Would you mind sending it again to my email?

Thank you. 

Userlevel 5
Badge +8

@DPA yes, asking the team to resend! The message came from @Jacenda Davis if you don’t mind checking your inbox and spam folder again. 🙏

Reply