Solved

Space in front of text in the rows and columns headings when export to csv from chart

  • 3 August 2022
  • 4 replies
  • 68 views

I always have huge spaces (tab?) in front of a text in every cell of heading when export data to csv. The only way how I can remove all these extra spaces fast enough is to create an extra column or row with a formula ‘=clean()’

Could anyone advise, please, what setting on my computer I need to change to fix this?

 

 

icon

Best answer by Thao Nguyen 4 August 2022, 17:32

View original

4 replies

Userlevel 2
Badge +5

Hi @elena_grant 

Thank you for writing in! Happy to help!

Our engineering team modified exported CSVs to include additional quotation and tab characters in front of all values as a preventative measure for a security risk known with CSV downloads (details here). Attackers can potentially use a formula to inject false data or leak data. And in order to prevent formula triggering cells from running, our engineering team revamped our CSV exports by prefixing quotation and tab characters in front of all values.

 

With that being said while that security issue remains we received feedback from customers who said that they were willing to take that risk. Therefore, we implemented a way to export CSVs from Amplitude without any characters in front for those users.

 

If you are willing to take that risk as well you can enable the feature to remove the spaces in your CSV in your Org Settings section on the Profile page. You can scroll down and turn off leading spaces in CSV with the toggle on that page.


If you are not willing to take that risk one possible solution for Excel you could try to eliminate the additional characters, you can use the following formula: TRIM(CLEAN(cell)).

 

Hope this helps! Please do let me know if you have any more concerns about this.

 

Best regards,

Thao

Thank you @Thao Nguyen. Your explanation makes perfect sense. 

Best Regards,

Elena.

I found one more quick fix for removing all tab characters. Open csv file with a text editor (Notepad or VS Code), use Find/Replace and save it back, then open it with Excel.

Userlevel 2
Badge +5

You are welcome, @elena_grant! Thank you for sharing the workaround 🙂 We appreciate it!

Reply