Amplitude Hubspot Integration: List Created and Not Populated

Badge +1

I’m running into problems getting Amplitude Hubspot Integration to work.

I’ve followed the instructions detailed in Send Cohorts to HubSpot and they seem to almost work.

However, when i examine the Cohorts in HubSpot, I find that a contacts list is created with the correct name, i.e. with the Amplitude_ prefix, but the list is empty and remains empty despite Amplitude claiming it has synced users to the list.

17 replies

Userlevel 4
Badge +5

@kdavis welcome and thanks for raising this issue. I’ve asked our support team to troubleshoot and see if they can replicate.

Userlevel 6
Badge +8

Hi @kdavis ! Welcome to the Amplitude Community 👋

If the contact list is created with the correct name in Hubspot, that should represent that the sync was successful and completed. Did you see any errors pop up in the Cohort Sync Details section within Amplitude or maybe errors in Hubspot? That would help with troubleshooting. 

Otherwise, the only other reason I know users not appearing in a cohort sync destination is because the user doesn’t exist in the destination already. I see that with the Hubspot integration, if you choose Contact ID as the mapping key for example, then the user has to exist in Hubspot: Can you share if this is how you have set up your integration? 

Badge +1

Hi @belinda.chiu !

Thanks for helping!

I’ve may a bit of progress with this problem, but only a bit.

I’ve found that if when creating the sync I do the following:

  1. Select my API key
  2. Enable “Upsert Anonymous Users” (So the user need not already exist in HubSpot)
  3. Select “One-Time Sync”

then a corresponding static list is created in HubSpot and the list is populated with the current members of the cohort with no errors in the Details section of the Amplitude cohort.

However, I want the HubSpot list to be updated with new members of the Amplitude cohort. So, I then edit the sync schedule of the Amplitude cohort to have the sync happen hourly, and this is where the problems begin.

The history of the cohort sync in Amplitude looks perfect with no errors, e.g. lots of….


450 users (11 added, 2 removed)

May 19, 2023, 6:50:45 am 

However, the added users do not appear in the corresponding HubSpot list. (I don’t even know where the log is on the HubSpot side so I don’t even know where to look for errors on their side.)

However, it seems like removals from the HubSpot lists are synced, i.e. for the Amplitude History item I provided above 2 users would be removed from the HubSpot list, but no users would be added.

So things are a bit strange. 

PS: If you need more specific info on the setup, just ask.


Badge +1

@belinda.chiu @Esther Trapadoux Is there any possibility I can get a detailed log of the syncs so I can try and debug why only a small percentage of them are succeeding? (No errors appear in the Cohort Sync Details section of Amplitude.)

Userlevel 6
Badge +8

Hi @kdavis ! Thanks for the info you provided earlier. I reached out to the Engineering team with that info and they responded with the following: 

The “[Hubspot] Users Validating ...” cohort does not have upsert enabled.

Since they did successfully sync them with a one-time sync and then edited the schedule, it looks like the upsert flag was reset to false. We’ll take a look at whether this is expected behavior

If they disable their current syncs and create a new sync for each of the two cohorts, they should be able to enable upsert and have their syncs working.

Could you try the Engineering team’s suggestion and let me know if that works? 

Do you recall whether you had upsert enabled when you created the syncs the first time around? 

Badge +1

@belinda.chiu Thanks for tracking this down! I’ll try their suggestion.

PS: I did have upsert enabled initially.

Badge +1

@belinda.chiu I’ve tried it for all the cohorts, meaning I….

  1. Edited the sync schedule
  2. Turned off the sync schedule
  3. Saved the schedule with sync off
  4. Edited the sync schedule
  5. Selected a sync schedule, daily or  hourly dependent upon the cohort
  6. Saved the schedule with sync on

Now I’ll just wait at least an hour to see what happens.

Badge +1

@belinda.chiu Still doesn’t work.

For example, since I wrote the last message there are about 33 more users in the [HubSpot] Users Validating Email Within the Last Day cohort, but 0 of those have been added to the corresponding list in HubSpot.

Furthermore, the sync history indicates 35 added, 2 removed with no errors for the last 14 days.

Userlevel 6
Badge +8

Hi @kdavis ! To clarify, you created new scheduled syncs right? So the steps are:

  1. Delete/disable the current sync schedule on the cohort
  2. Create a new fresh sync schedule on the cohort with the Upsert enabled

I’m assuming that’s what you did based on the Engineering team’s suggestion but the steps you shared are slightly different from how I was imaging. Wanted to confirm! 

Badge +1

Hi @belinda.chiu ,


Thanks for followup up!

What I did is what I captured in the steps a listed above.

In particular your step “Create a new fresh sync schedule on the cohort with the Upsert enabled” isn’t possible with the current Amplitude + HubSpot integration.

Setting upsert on or off is only exposed when creating a cohort from scratch. It isn’t exposed once the cohort is already created. Once a cohort has been created you can only do what I did above.

That said, if I were to delete the cohort completely and create a new cohort with upsert enabled and a hourly or daily sync set, then I’d be in the original situation I found myself in when I opened the ticket, i.e. a cohort is created and claims to sync every day or hour and an empty list is created on the HubSpot side and the list remains empty.

The only way I’ve been able to have data be sent to HubSpot is to create a cohort with upsert enabled and also select a one-time sync. If I do this, then a list get created and populated on HubSpot. After that I then set the sync to hourly or daily. But then, as explained above, the sync doesn’t work.

Userlevel 6
Badge +8

Hi @kdavis ! Thanks for sharing this! Do you mind if I test some things in your cohorts? I’ll email you separately. :) 

Badge +1

@belinda.chiu Sounds good to me.

Badge +1

@belinda.chiu Wondering if you’ve made any progress on this?

Userlevel 4
Badge +5

@kdavis thanks for the nudge 😅 @belinda.chiu is actually OOO this week but I’ve asked another team member to jump into this.

Badge +1

@Esther Trapadoux Hopefully you have some updates!

Userlevel 6
Badge +8

Hi @kdavis ! I’m ooo this week and will ask another team member to help. In the meantime, I did send an email last week to your email associated with the Amplitude Community post to confirm the two cohorts that you were attempting to sync and permission to disable those syncs and recreate a new one. I just checked the email and it looks like I haven’t heard back from you yet on confirming those two cohorts. Could you check your email inbox? Thank you! 

Badge +1

Hi @belinda.chiu ,

I didn’t receive an email from you, not sure what happened.

Least email I got was the one containing

Thanks for sharing this! Do you mind if I test some things in your cohorts? I’ll email you separately. :)