Solved

Amplitude shows "idfa" and "adid" as null in raw payload

  • 11 July 2021
  • 3 replies
  • 38 views

Badge

When I view the json for my events in Amplitude it shows idfa and adid as null, although we are sending those ids in our payload via http apis.

RAW Json

--------------

{
  "$insert_id": "89b828b9-b7a3-40be-acaf-5379a905354c",
  "$row_source": "realtime",
  "$schema": 12,
  "_time": 1625966110148,
  "adid": null,
  "amplitude_attribution_ids": [
    "64f3c30eb974ecdae63f596b63fe8406"
  ],
  "amplitude_event_type": null,
  "amplitude_id": 277790090847,
  "app": 312573,
  "city": "Dar es Salaam",
  "client_event_time": "2021-07-11T01:15:10.148",
  "client_upload_time": "2021-07-11T01:15:10.148",
  "country": "Tanzania",
  "data": {},
  "device_brand": null,
  "device_carrier": "VodaCom",
  "device_family": "Android",
  "device_id": "devic_id-0002",
  "device_manufacturer": null,
  "device_model": "Android",
  "device_type": "Android",
  "display_name": "Cart View",
  "dma": null,
  "event_id": 179180944,
  "event_properties": {},
  "event_time": "2021-07-11T01:15:10.148",
  "event_type": "Cart View",
  "group_properties": {},
  "groups": {},
  "idfa": null,
  "ip_address": "197.250.227.52",
  "is_attribution_event": false,
  "language": "English",
  "library": "http/2.0",
  "location_lat": null,
  "location_lng": null,
  "os": "14.4.1",
  "os_name": null,
  "os_version": "14.4.1",
  "paying": null,
  "platform": "Andriod",
  "region": "Dar es Salaam Region",
  "sample_rate": null,
  "server_received_time": "2021-07-11 01:15:10.148000",
  "server_upload_time": "2021-07-11T01:15:10.162",
  "session_id": -1,
  "start_version": "21.8.0",
  "timeline_hidden": false,
  "user_creation_time": "2021-07-11T01:15:09.47",
  "user_id": "user_id-010",
  "user_properties": {
    "Install Date": "2021-03-30",
    "Postal Code": "95035",
    "applOpenCounter": "123",
    "optedOut": "false",
    "userAgent": "WMT1H/21.8 iOS/14.4.1"
  },
  "uuid": "70200b50-e1e5-11eb-bded-02bc10515bc7",
  "version_name": "21.8.0"
}

icon

Best answer by Nadia 12 July 2021, 10:21

Hi there! Thanks for writing in. Happy to answer! Amplitude removes the ADID information due to privacy concerns. We process the attribution information but strip the ADID before saving the event in our system. That’s why you don’t see any values in Amplitude.

Do you mind elaborating why you’d like to see these? Are you trying to troubleshoot an issue?

View original

3 replies

Userlevel 2
Badge +2

Hi there! Thanks for writing in. Happy to answer! Amplitude removes the ADID information due to privacy concerns. We process the attribution information but strip the ADID before saving the event in our system. That’s why you don’t see any values in Amplitude.

Do you mind elaborating why you’d like to see these? Are you trying to troubleshoot an issue?

Badge

Hi, Nadia.

The intention was to see whether our attribution flow is working correctly or not. Our attribution data is flowing from a 3rd party vendor while the events are flowing into Amplitude via server-to-server pipeline.

 

 

Userlevel 2
Badge +2

Thanks for sharing @shahidxali. That makes total sense. Are you seeing any attribution data in Amplitude? If the answer is yes and you see the attribution data being tied to the users, you can be certain that the adid is being sent successfully!

If the answer is no, and you are certain that you are sending the adid, please keep in mind that attribution events will be held for up to 72 hours for potential user matching. If a user didn’t perform an Amplitude event within the 72 hours of the attribution event, the attribution data will be dropped.

Reply