Some events not showing on traking plan

  • 1 August 2022
  • 4 replies

Hi, our company recently started using Amplitude for data tracking, and I started by implementing my tracking plan. I imported the plan via csv, but found some typos, and missing events which I added through the Data(beta) platform. 

My current issue is that some of the events I’m emitting from my application are not being tracked, they do not show up on the plan, not even as invalid events, and if I try to add the even manually I get the error message “Unable to create an event with a name that already exists.” 

Should I delete the whole tracking plan for now and start over?


Best answer by eddie.gaona 3 August 2022, 01:08

View original

4 replies

Userlevel 5
Badge +9

Hello @Jesus Ugueto warm welcome to the Amplitude Community :)


My understanding, is that you are having issues with Amplitude Data where events that you are tracking are not appearing within the tracking plan. To further assist you with this mystery could you provide a list of events that are missing and causing the “Unable to create an event with a name that already exists”, please?

Hi @eddie.gaona yes, the following events are giving me the mentioned error

"Click: Solicitar Oferta 1"
"Click: Datos del comercio - Continuar"
"Click: Dirección comercial - Continuar"

For more information, initially I had a typo on the events, so I tried to edit them, but I kept seeing the wrong name, so I deleted them, and afterward when trying to add them back, the error started showing

Userlevel 5
Badge +9

@Jesus Ugueto Thank you for the information!

A couple of notes here:

  • Deleting an event
    • This action will stop all data coming in for the event from appearing in Amplitude as detailed, here.
    • It will also prevent you from creating a new event with the same name.

My recommendation would be to go ahead and undelete the 3 events mentioned:

  • "Click: Solicitar Oferta 1"
  • "Click: Datos del comercio - Continuar"
  • "Click: Dirección comercial - Continuar"

I know you mentioned that you tried to rename the events but ran into an error. Could you show me a screenshot or recording of the error you are seeing? How are you trying to rename the events? Do you follow these steps:

  1. Click on the event (example:"Click: Solicitar Oferta 1" ) - right panel opens


  2. Click on the event name to edit
  3. Rename the event and press enter


Let me know if it’s alright with you to rename an event within your tracking plan to be able to replicate the error. If so, which event can I test?

Thanks @eddie.gaona, undeleting the events did the job. And the bug on editing the event name haven’t happend again