Solved

Missing events and user Properties on some users

  • 23 January 2023
  • 3 replies
  • 54 views

Hey! 

We are currently using the Android and iOS SDK. And it works great in most cases.

However we have found a problem with the Android side that results in missing some events and user properties.

What seems to happen is that the first events happening is sometimes not being uploaded to your database.

So we can see that some users is in a screen_view that should not be possible to begin the session with. That’s why it seems to be a problem with uploading event. We have an initial step with uploading user properties, such as: android_logged_in: yes/no. But those will not be uploaded.

 

This results with an average of 5 new users missing this property each day. which is just a tiny percentage but still annoying.

 

Do you have any tips how to solve this? 

icon

Best answer by JonathanN 31 January 2023, 09:53

View original

3 replies

Userlevel 5
Badge +9

Thanks for reaching out here @JonathanN. I was able to find this troubleshooting guide - link. This implementation resource - link - is a good place to start too. Please keep us posted if you need any additional assistance. 

Userlevel 5
Badge +9

Hi @JonathanN I hope all is well. I wanted to check in. Were you able to make progress here?

Hey! We were able to solve it, it was caused by when a user authenticate with another loginmethod or email, the user will not get the user property transferred which is good, but some of the user properties were then not logged for the new user. So it is fixed now, thanks! :)

Reply