Import S3 not working

  • 21 November 2022
  • 4 replies


Was following this guide on importing data from a data warehouse in S3:

Creating the role worked fine and creating the Amazon S3 import source worked fine until step 6. The test credentials step was able to pull the files we have stored in S3 and show them back to me but on the next screen, when I entered a data source and description and hit save nothing happened.

Thanks for the help!


Best answer by jarren.patao 22 November 2022, 01:22

View original

4 replies


Made sure that our files have 1 event per line and are in JSON format. Even followed an example event from another question: 

But still no luck


For anyone wondering about this in the future- ended up going with a direct DynamoDB stream (since that’s our primary source) to a Lambda that writes events to Amplitude as opposed to going through the S3 data warehouse

Userlevel 4

Hi @nar, sorry to hear you had experienced a bit of issues during setup. It’s helpful to understand what errors you might be experiencing when attempting to save this destination. If there are any errors being thrown in the browser console then this also help us understand what you might be experiencing when you finalize this S3 Import source.

Otherwise, I’m glad to hear you were able to get a working setup with your DynamoDB stream!


Hi thanks for your response. No errors at all but was able to get it working so all good!