Only server events in Event Stream

  • 28 December 2021
  • 8 replies
  • 77 views

Badge

Hi everyone!

 

We found one user, he play for 121 day in our game, but in his event stream he has only server events.

 

 

All others players tracks normal


8 replies

Userlevel 5
Badge +8

Hi @Kilyavi ! Welcome to the Amplitude Community! :wave:

If I am understanding the situation correctly, you expect to see both client-side and server-side events on users’ profiles. However, for this particular user, you only see server-side events. 

Can you share with me if it is possible for a user to only have server-side events? Or are these server-side events only possible based on actual user actions from client-side? 

Also what are you using to track client-side events? Are you using our SDKs and if so which one? 

Badge

Hi, thanks :)

No, it’s not possible to have only server events. All based on user actions. Nornally server events it’s only 1%-5% of all.

We use SDK, but I can’t answer, which one. I’ll ask it only tomorrow.

Badge

We use Unity version of SDK

Badge

Hi! Still no ideas how it may be?

Badge

Hi @belinda.chiu ! You still have no ideas? Or maybe need some more information?

Userlevel 5
Badge +2

Hi @Kilyavi I hope you’re doing well. Somehow this thread was missed. Were you able to make progress? We’re here to help if you need anything! 😀

Badge

Hey @Jeremie Gluckman ! Nope, problem is not solved. Now we have much more cases like that. Difference between Google Analytics and Amplitude is ~50 users in this month (390 and 340). I suppose, it may be because of sanctions and russian users.

 

Userlevel 4
Badge +7

Hi @Kilyavi!

Happy to step in here.

It is common to see discrepancies in the number of users between Amplitude and other analytics vendors such as GA. We have an article here that might be insightful! https://help.amplitude.com/hc/en-us/articles/115002383247-Understanding-Data-Discrepancies

For your original question, a possibility might be that the events from the SDK for this user are being logged under a separate user profile. You might want to look at how you’re identifying users, especially if they are anonymous. Here is an article on how Amplitude identifies and merges users: https://help.amplitude.com/hc/en-us/articles/115003135607-Track-unique-users-in-Amplitude

Another possibility might be that your SDK was not initialised/instrumented correctly, and the events were never fired. You can check your response codes for these events to see if you actually got a 200 response code. 

Reply