Question

Not all event are ingested over time. NodeJS

  • 3 September 2021
  • 3 replies
  • 42 views

Badge

I have 1 test project and 1 production.

After a proper configuration and tests, we’ve launched analytics in our application, but over some time, some events stopped working at the beginning on test project and a little bit later on production.

Limits data is fine. More over most of the events are still coming.

 

Event Limit

10M / month

Events Last Month

68

Events This Month

35

Event Usage

35 of 10,000,000 (0.000350%)
 
just to make sure that all properties are passing the validation requirements I’ve tried
- to remove all properties and send a plain event with no data
- to remove insert_id as a unique id per event
- change and remove identify propeties
 
the only thing that worked is changing the name of the event. so like before it was `event_name` and after it became `event_name2` and it worked, but I’m still wondering why could it happen so, that only some events are not ingested properly?
 
changing a test project also helped, but I don’t see any difference in configuration of the project

3 replies

Userlevel 3
Badge +4

Hello @kimslava.namba 

Sounds like events have stopped ingesting into your Amplitude projects. 

I would recommend checking if the events or properties have been blocked/deleted through the Govern page of each project. Have you tried sending in the event via the HTTP API to test?

There are no limits on our end that would prevent events to stop ingesting over time.

Badge

Thanks for your answer,

and yes I’ve checked all steps you’ve mentioned on several projects.

1st project had some events deleted, but those were reverted, and still it does not ingest events

2nd project doesn’t have any event being deleted, and event deactivated or anything like that. I’ve tested it with both empty properties, thinking that it could be a problem, but still no result.

also I’ve tried to send it via HTTP API, and still result is the same, only some specific events, either with or without any parameters, are not ingested.

For example I have event that cannot be accepted called `sign_in_failed`, and for some reason nothing make it to be ingested, except sending it to another project or sending it with all the same parameters but with different name for example `sign_in_failed2` then it start working

Userlevel 3
Badge +4

Hello @kimslava.namba 

I will follow up in an email thread as this will take longer to troubleshoot without being able to see your org.

Reply