Solved

gerting a deprecation error using flutter

  • 2 July 2022
  • 1 reply
  • 20 views

Userlevel 2
Badge

I get the following error in iOS build. it looks like the flutter package is using a deprecated method. 
 

/Users/builder/programs/flutter/.pub-cache/hosted/pub.dartlang.org/amplitude_flutter-3.10.0/ios/Classes/SwiftAmplitudeFlutterPlugin.swift:127:64: warning: 'logRevenue(_:quantity:price:)' is deprecated: Use `logRevenueV2` and `AMPRevenue` instead
                    Amplitude.instance(withName: instanceName).logRevenue(productIdentifier,

 

 

icon

Best answer by Denis Holmes 4 July 2022, 18:18

View original

1 reply

Userlevel 6
Badge +8

Hi @assembly ,

 

Is this with the most recent upgrade? If so, can you revert to the previous version for now? If that is the case, can you then PM me your Org ID and the Flutter SDK version you are using and I will log a ticket for it. However, please expect delays as we are observing a company-designated week-off from July 4-8. Support(like right now) will be online for coverage but the Product Development team will only be available for major incidents/bugs. Thank you for your patience and understanding!

 

Kind Regards,
Denis

Reply