Solved

Can't install amplitude SDK to Python - "pip install amplitude" failed

  • 17 July 2022
  • 6 replies
  • 60 views

I am using Pycharm. Trying to 

pip install amplitude
 

The error is:

ERROR: Could not find a version that satisfies the requirement amplitude (from versions: none)
ERROR: No matching distribution found for amplitude
 

Has anybody faced it?

icon

Best answer by Denis Holmes 19 July 2022, 12:29

View original

6 replies

Userlevel 6
Badge +8

Hi @Sergei ,

 

I have not come across this before but I am not overly familiar with Pycharm in recent years. Have you tried the correct install? According to our documentation here, you need to run the command “pip install amplitude-analytics” to install the package. Did you try that? If so ;
1. Can you make sure there are no VPNs or Adblockers.
2. Can you read through the installation fully and try again? 
3. Can you reinstall Pycharm and try again?
4. Please post a screenshot of the error you get when you do run the command and I will see what I can do!

 

Kind Regards,
Denis

Hi Denis,

Yes, I’ve installed the SDK according to the docs and there were no problems. I just run:

pip install amplitude-analytics

and there were no visible problems with that.

There are no blockers and I’ve reinstalled the Pycharm again. I followed the basic tutorial and now get the following error:

What could it be? Do you have any ideas how to fix it?

Thanks, Sergey

Userlevel 6
Badge +8

Hi @Sergei ,

 

Which version of Python are you running? Can you try to see if you get the same issue with Python 3.7 and 3.8? I do hear some issues with this error with Python 3.9 so I am curious as to the version you have for Python? Can you use versions 3.7 & 3.8 and see if either of them work? 

Is it possible to test this on a different machine and see if you get the same issue? can you also try a different network and try send the event again? Thank you!

Hi @Denis Holmes

You were absolutely right regarding the version issue. I’ve tried 3.10 (the latest on Python website) and 3.9 and got the same issue. Verion 3.7 worked well for me and I managed to send the event data via API.

Thanks for your help!

Regards, Sergei

Userlevel 6
Badge +8

My pleasure! 

I’m still seeing the original error: 

ERROR: Could not find a version that satisfies the requirement amplitude-analytics (from versions: none)

#0 0.635 ERROR: No matching distribution found for amplitude-analytics

Is there a plan to make this SDK available in later versions of Python?

Reply