Solved

ampli pull error: Error: The organization does not have any workspace

  • 14 February 2022
  • 4 replies
  • 102 views

Badge

Hi everybody!

I am trying to do my first amplitude project using CLI and trying to use te SDK.

The SDK was installed and when I try to run the command ampli pull, when I enter the credentials, it recognizes the organization, but it won't let me create a project because there is no workspace.

 

 

What´s the difference between project and workspace? How can I create the workspace for the organization?

 

Thanks!

icon

Best answer by sydney.koh 16 February 2022, 01:00

View original

4 replies

Userlevel 5
Badge +8

Hi!

 

A workspace is just an area in Amplitude where you browse your Amplitude content in one place. A project is where you send your data to and each project is typically a app or website. In order to make a project and start sending data into Amplitude you need to log into our platform then create a project using the UI. Then, we will generate a API key for the project which will allow you to start sending data. You cannot use the SDKs to initialize a new project. I recommend using this quick start guide:

https://help.amplitude.com/hc/en-us/articles/207108137-Quick-start-guide-Create-your-organization-and-first-project 

 

Best,

Sydney

Userlevel 2
Badge +1

Hi @Natalia1190, I believe your organization doesn’t have Iteratively enabled yet based on the error. If it is ok, maybe we can connect and enable Iteratively for your organization, and walk through the Iteratively product, Ampli Cli and Ampli SDK? 

Badge

Hi @qingzhuo!

At the moment, we are exploring other options. We will research what is the better option.

Tahnks a lot!

Userlevel 2
Badge +1

Hi @Natalia1190 No problem, if you still want to explore Ampli SDK option in your research, feel free to let us know and we are happy to show more for you. I created a post draft some basics about Ampli SDK. Hope that can also help. 

Reply